Uw netwerkspecialist

High Availability met HSRP

Hot Standby Router Protocol (HSRP) is een protocol om fout tolerantie te maken met twee of meer layer-3 interfaces. Met HSRP is het mogelijk om een virtueel IP adres te koppelen aan meerdere interfaces. Het adres is dan actief op één interface, zodra dit interface niet meer beschikbaar is dan zal een andere interface het IP adres overnemen.

HSRP is een Cisco Proprietary protocol, een gestandaardiseerd open protocol, gebaseerd op dezelfde principes en met ongeveer dezelfde werking, is Virtual Router Redundancy Protocol (VRRP). Dit is een protocol wat men vaak terug vindt bij oa. Loadbalancers of VPN Gateways, ook wordt VRRP tegenwoordig ondersteund door Cisco routers.

HSRP stuurt een periodiek pakket naar 224.0.0.2 (Multicast All Routers) op poort 1985. In dit pakket staan bijvoorbeeld prioriteit, HSRP groep, Router ID en Authenticatie.De router met de hoogste prioriteitswaarde zal op ARP aanvragen voor het virtuele IP adres antwoorden met MAC adres 0000.0c07.ac<group ID>, bijvoorbeeld group ID 10 krijgt MAC adres 0000.0c07.ac10 en groep ID 1 krijg 0000.0c07.ac01. Hierdoor krijgt iedere HSRP groep een uniek MAC adres en hoeft men bij een failover niet te wachten op de ARP timeout.

HSRP op Cisco routers is redelijk eenvoudig te configureren en wordt ondersteund in de meeste Cisco Routers en layer-3 switches zoals de 3750, 4500-serie en 6500-serie. HSRP wordt daarnaast ondersteund voor zowel IP versie 4 als IPv6.

HSRP op een Cisco 3750:

node 1:

interface GigabitEthernet1/0/1
ip address 10.100.1.254 255.255.255.0
standby 1 ip 10.100.1.1
standby 1 timers 1 2
standby 1 priority 20
standby 1 preempt
standby 1 authentication geh31m

node 2:

interface GigabitEthernet1/0/1
ip address 10.100.1.253 255.255.255.0
standby 1 ip 10.100.1.1
standby 1 timers 1 2
standby 1 priority 25
standby 1 preempt
standby 1 authentication geh31m

De timers zijn in deze configuratie erg strikt ingesteld omdat dit een Voice over IP omgeving betreft. In een data netwerk is het aan te raden om de hello-time (dit geeft aan hoe vaak het HSRP pakket uitgestuurd wordt naar het Multicast adres) wat hoger te zetten in verband met de overhead in het netwerk.

Een voorbeeld van dezelfde configuratie met IPv6:

node 1:

interface GigabitEthernet1/0/1
no ip address
ipv6 address 2001:610:7bb:beef:221::aaa1/64
standby version 2
standby 1 ipv6 FE80::1:CAFE
standby 1 ipv6 2001:610:7bb:beef:221::1/64
standby 1 timers 1 2
standby 1 priority 20
standby 1 preempt
standby 1 authentication geh31m

node 2:

interface GigabitEthernet1/0/1
no ip address
ipv6 address 2001:610:7bb:beef:221::aaa2/64
standby version 2
standby 1 ipv6 FE80::1:CAFE
standby 1 ipv6 2001:610:7bb:beef:221::1/64
standby 1 timers 1 2
standby 1 priority 25
standby 1 preempt
standby 1 authentication geh31m

Het is ook mogelijk om HSRP te gebruiken om aan “load sharing” te doen. De truc hiervoor is eenvoudig, men maakt simpelweg twee HSRP groepen aan met tegenovergestelde prioriteiten. Vervolgens zet verdeelt men de gateways 50/50 over beide standby adressen.

node 1:

interface GigabitEthernet1/0/1
ip address 10.100.1.254 255.255.255.0
ipv6 address 2001:610:7bb:beef:221::aaa1/64
standby version 2
standby 1 ip 10.100.1.1
standby 1 ipv6 FE80::1:CAFE
standby 1 ipv6 2001:610:7bb:beef:221::1/64
standby 1 timers 1 2
standby 1 priority 20
standby 1 preempt
standby 1 authentication geh31m
standby 2 ip 10.100.1.2
standby 2 ipv6 FE80::1:BEEF
standby 2 ipv6 2001:610:7bb:beef:221::2/64
standby 2 timers 1 2
standby 2 priority 25
standby 2 preempt
standby 2 authentication geh31m2

node 2:

interface GigabitEthernet1/0/1
ip address 10.100.1.253 255.255.255.0
ipv6 address 2001:610:7bb:beef:221::aaa2/64
standby version 2
standby 1 ip 10.100.1.1
standby 1 ipv6 FE80::1:CAFE
standby 1 ipv6 2001:610:7bb:beef:221::1/64
standby 1 timers 1 2
standby 1 priority 25
standby 1 preempt
standby 1 authentication geh31m
standby 2 ip 10.100.1.2
standby 2 ipv6 FE80::1:BEEF
standby 2 ipv6 2001:610:7bb:beef:221::2/64
standby 2 timers 1 2
standby 2 priority 20
standby 2 preempt
standby 2 authentication geh31m2

Deel dit verhaal:

Geschreven door:

Zoeken:
geen berichten gevonden.

Vragen? Ons professioneel team met experts staat voor u klaar!

Kennis van de modernste technieken, internet of things, DDos
bescherming, WIFI everywhere, Voip, bedrijfsnetwerken...

Maak een afspraak!